Follow

Replacing the LED Screen

Removing the LED Screen and Display Board

These instructions apply to the Ultimaker 2, 2 Extended, 2+, and 2+ Extended. The 2Go is similar, but has a different cover on it; instructions will be coming soon. The Ultimaker 3 and Ultimaker 3 Extended are very similar to this, but have an additional cable plugged into the Ulticontroller; additional instructions coming soon.

Tools Needed:

  • 2mm hex head screw driver, or 2mm allen key
  • pliers or M7 nut driver


The back of the clear plastic knob housing has a hole in it. Use a screwdriver (or similar) to push through the hole in the back and push the white knob front out of the front.

Use a pair of pliers to unscrew the hex nut and washer holding the clear plastic knob housing in place, and then pop the knob housing out.

Now you can unscrew the white metal cover over the Ulticontroller board. It's held on with two nuts, and two 12mm screws. When the screws and nuts are removed, you may want to push forward and pull up from the back to get the cover off. Then, unscrew the 4 screws holding the Ulticontroller board on.

Carefully slide the LED screen out of the recess in the front panel as you remove the Ulticontroller board. You will see a little black tab on either side of where the screen plugs into the board. Very carefully move those tabs forward to release the ribbon cable of the screen.

Installing the LED Screen

If you choose to unplug the EXP 1 and EXP 2 ports, please mark which cable came from which port so they can be plugged back in correctly.

Gently pull the small black tabs on the part of the board that holds the screen ribbon in place and ease it open.

Insert the new ribbon cable until the dark portion just about disappears beneath the black clip with the tabs on it, then carefully push the clip up to secure it.

It should be able to slide into it's slot on the front panel. Carefully hold the Display board in place as you screw the 4 screws in place that are holding it, and replace the display cover. The display cover is secured with 2 nuts and two 12mm screws. Do not pinch any of the cables between the cover and bottom panel; there is a slot in the corner for the cables to run through.

All finished and it doesn't work? Check out this troubleshooting article.

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.